Boost logo

Boost :

Subject: Re: [boost] Second iteration of Boost.XInt library uploaded, requesting further comments
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-04-01 07:25:57

Chad Nelson wrote:
> On 03/31/2010 01:26 PM, DE wrote:
> > i find 'nan()' member function confusing
> > i would have made 'nan()' a static function returning NaN
> > and renamed the former to 'is_nan()'
> > similarly 'odd()' and 'even()' could be 'is_odd()' and
> > 'is_even()' but these are less confusing to me [...]
> The nan function was named that way because it fits in with the naming
> of the even and odd functions (which n1694 specified). For what it's
> worth, I agree with you; the constructor taking a not_a_number object
> was my second choice, not my first.

There's still time to change the upcoming standard and you can lead the way now in your library. Consider submitting defects for these things to make future code more readable.

Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP

IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.

Boost list run by bdawes at, gregod at, cpdaniel at, john at