Boost logo

Boost :

Subject: Re: [boost] Message Hashing Interface (SHA-1/256/384/512, MD4/5)
From: Scott McMurray ([hidden])
Date: 2010-04-10 12:16:24

On 10 April 2010 11:45, Daniel Trebbien <dtrebbien_at_[hidden]> wrote:
> one, minor suggestion: why not name `end_message` simply `end`?
> I am of the opinion that naming should follow the language's standard
> library conventions closely. And, as the STL uses short, concise
> member function names, it is best to mimic this.

I picked that one thinking of the ASCII control codes END OF
TEXT/TRANSMISSION/MEDIUM and the email convention of <eom>. And I
realize it's not a member function, but STL isn't afraid of calling
something lexicographical_compare if it needs to.

As part of the
it's called "Finalization", and most precedents seem to use something
like that. Crypto++ calls it "Final", the MD5 reference
implementation uses "MD5Final", and the implementation provided for
the "best understood" (according to NIST) SHA-3 candidate CubeHash
( also calls it Final.

To get an actual verb, I guess the most logical name would be
"finalize()", but I suppose most libraries can't use that since their
GC stole the name.

Boost list run by bdawes at, gregod at, cpdaniel at, john at