Subject: Re: [boost] [xint] Third release is ready, requesting preliminary review
From: Chad Nelson (chad.thecomfychair_at_[hidden])
Date: 2010-05-04 13:36:43
-----BEGIN PGP SIGNED MESSAGE-----
On 05/04/2010 01:17 PM, Jeffrey Lee Hellrung, Jr. wrote:
>>> Your use of enable_if could be simplified into a single argument
>>> for the integer constructors by using mpl::and_.
>> Thanks for the suggestion, but I'd like to keep the dependencies
>> and compile times at a minimum. [...]
> IMHO, using multiple "typename enable_if<...>::type* = 0" in a
> constructor is just fine. It makes the clauses line up a little
> more uniformly (to me). Just remember, you'll have to use
> boost::mpl::and_ (or similar) if you need short-circuiting.
Thanks for the tip. I hadn't even considered a need to short-circuit the
enable_if evaluations, or that there might be a way to do it if I had one.
Oak Circle Software, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
-----END PGP SIGNATURE-----