Subject: Re: [boost] [rfc] Preliminary Hash Library
From: Minh Phanivong (m_phanivong_at_[hidden])
Date: 2010-05-08 11:08:43
How about boost::hash_algo?
Sent from my iPhone
On 08/05/2010, at 11:51 PM, "Stewart, Robert" <Robert.Stewart_at_[hidden]> wrote:
Scott McMurray wrote:
On 6 May 2010 06:01, Daniel James <dnljms_at_[hidden]> wrote:
This will collide with the existing 'boost::hash' (an implementation
The simplest fix would be just changing the namespace to
boost::hashes. Alternatively, the library could be renamed to
Cryptographic_Hash and use boost::cryptographic_hash as its namespace,
though that would cut off the possibility of following Paul Bristow's
Adding just one letter at the end makes for a rather slim differentiator, but I don't think it will hurt. We already have boost::tuple and boost::tuples, right?
Unless you intend to create the Boost Cryptographic Hashing Library versus one that supports a wider range of hashing algorithms, don't include "cryptographic" in the name or namespace.
What about Boost Hashing Algorithms Library with namespace boost::hashing_algorithms? A handy namespace alias would be "hal" or "ha." ;)
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk