Subject: Re: [boost] Namespace for a Boost Hashing Library
From: Rhys Ulerich (rhys.ulerich_at_[hidden])
Date: 2010-05-09 23:05:03
> I initially used boost::hash, forgetting that the unordered containers
> have already claimed that name. A number of alternatives have been
> proposed, so I hoped to get some thoughts from the wider community.
Stealing from Wikipedia...
"The values returned by a hash function are called hash values, hash
codes, hash sums, checksums or simply hashes."
... what about boost::hash_codes.
Most other things that have been suggested sound fine. However,
abbreviating algorithm as algo as part of hash_algo drives me batty.
It doesn't break the word on a syllable. Moreover, said aloud it
sounds like either a cheesy superhero or a poorly made automobile.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk