Boost logo

Boost :

Subject: Re: [boost] 1.43 build broken on MSVC 8.0
From: Vladimir Prus (ghost_at_[hidden])
Date: 2010-05-11 11:07:46

Stephan Menzel wrote:
> Again:
> On Tue, May 11, 2010 at 4:41 PM, Stephan Menzel
> <stephan.menzel_at_[hidden]> wrote:
>> I've tried all sorts of command lines and user-config.jam I could
>> think of, but no effect.
>> Here's what I usually do:
>> ./bjam.exe --architecture=amd64 --address-model=64 -j2 link=shared
>> threading=multi variant=debug,release stage
> As always, I didn't try the one that mattered and only _after_ my post:
> linkflags="/MACHINE:x64"
> And it works.
> I never knew this one existed, and I suppose it should have been set
> by the toolset itself. So I guess this is indeed a bug, right?

Probably not -- you command line appears to be wrong. Neither
--architecture=amd64 nor --address-model=64 ever worked. If you try:

        ./bjam.exe architecture=amd64 address-model=64 -j2 link=shared

does it behave better?

- Volodya

Boost list run by bdawes at, gregod at, cpdaniel at, john at