Subject: Re: [boost] Namespace for a Boost Hashing Library
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-05-17 12:30:36
Scott McMurray wrote:
> On 11 May 2010 05:40, Phil Richards
> <news_at_[hidden]> wrote:
> > If the name "algorithm" is going to be in the namespace at
> > all, wouldn't
> > it make more sense to put it under boost::algorithm (either
> > directly, or as a nested namespace)?
> That's a good point. The only quibble I'd have is that
> boost::algorithm::hash::digest looks like a verb, and I
> do need the one noun.
"hashes" can still be taken as a verb, but we're predisposed to think of namespaces as things (they are scopes), so we're likely to consider "hashes" as the plural of the noun "hash."
That isn't a noun, but clearly describes the contents as related to hashing algorithms. I rather prefer that.
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.