Subject: Re: [boost] [boost::endian] Request for comments/interest
From: Tomas Puverle (tomas.puverle_at_[hidden])
Date: 2010-06-01 12:07:33
> An API with only from and to functions doesn't preclude it, but it does make
it less efficient.
That was the intent of my response.
> Indeed, I'm suggesting a larger interface because I'm including your interface
and adding more. The
> result is three categories of functions, ignoring overloads:
> That's not complicated or confusing, is it?
Ok. I was on the verge of yielding to the "to" and "from" syntax in my previous
That would satisfy your concerns, correct?
> I agree that is a better approach. You might consider adding the reverse
choices for completeness: "Y_from_X."
Sure, will do.
Again, thanks for the feedback.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk