Boost logo

Boost :

Subject: Re: [boost] [boost::endian] Summary of discussion #1
From: Tomas Puverle (tomas.puverle_at_[hidden])
Date: 2010-06-02 15:34:44

> How about putting
> "endian_cast" in the boost namespace and the other names in the boost::endian
namespace, providing for
> the following usage?
> using namespace boost::endian;
> endian_cast<big_to_little>();
> endian_cast<from_little>();
> endian_cast<to_big>();

Sure. Looks good.

By the same reasoning, we should also have a boost::endian_swap<>(), no? (Which
would be the 'in-place' version)

Boost list run by bdawes at, gregod at, cpdaniel at, john at