Subject: Re: [boost] [boost::endian] Summary of discussion #1
From: David Abrahams (dave_at_[hidden])
Date: 2010-06-02 17:31:48
At Wed, 2 Jun 2010 18:06:19 +0000 (UTC),
Tomas Puverle wrote:
> > That looks a lot like a cast, though the type doesn't change in your design, >
> so naming it something like "endian_cast" is not unreasonable.
> Since the type isn't supposed to change, I don't like the cast<> idea too much.
> But let me sit on it.
> > Otherwise, swap_in_place<>() could be named "swap" while your swap<>()
> > could be named something like "swapped_copy."
> These are good names - I might steal them ;)
I'd go with âswapâ and âswapped.â
-- Dave Abrahams BoostPro Computing http://www.boostpro.com