Subject: Re: [boost] [boost::endian] Summary of discussion #1
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-06-03 12:42:47
Tomas Puverle wrote:
> Dave Abrahams wrote:
> > > I'd go with "swap" and "swapped."
> > Amending that: watch out for unintended ADL effects with
> > "swap." It's one of those globally claimed names whose
> > meaning (at least with two arguments) is fixed for all
> > time w.r.t. unqualified calls.
Yeah, it's probably best that we not risk such problems.
> I think the consensus was to use "endian_cast" for the
> function which returns a swapped copy of the underlying
> data and "endian_swap" for the function which performs
> the swapping in place (Rob's suggestions).
"endian_swap" was, I think, your suggestion. I'm not sure I like it. How about "reorder?"
> Even though I dislike the endian::endian_cast<> syntax, my
> personal preference would be to have endian_cast in the
> endian namespace for "cleanliness" issues - I may well be
> ok with
> using namespace boost::endian;
> in my local scope to but I will not be ok with doing
> using namespace boost;
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.