Boost logo

Boost :

Subject: Re: [boost] [boost::endian] Summary of discussion #1
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-06-03 15:03:45

David Abrahams wrote:
> Tomas Puverle wrote:
> >
> > using namespace boost::endian;
> > int i = endian_cast<from_big>(j);
> Ouch. Normally the destination type is in the <>s of a cast. Why not
> just two functions:
> boost::endian::from_big( x )
> boost::endian::from_little( x )

I had proposed boost::endian::from<big_endian>() and boost::endian::to<big_endian>(), but I thought the copying and transformational aspects of these functions was highlighted a bit better by the new-style cast notation.

That the current and target endiannesses could be specified similar was a nice consistency:


Using distinct functions means something like this:


There's nothing wrong with that approach, but we thought the cast notation was clean.

Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP

IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.

Boost list run by bdawes at, gregod at, cpdaniel at, john at