Boost logo

Boost :

Subject: Re: [boost] [boost::endian] Summary of discussion #1
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-06-04 06:54:13


vicente.botet wrote:
> Terry Golubiewski wrote:
>
> > template<size_t Bits, endian_t Endian=native>
> > class PackedInteger {
> <snip>
>
> template <BOOST_SCOPED_ENUM(endianness) E, typename T,
> std::size_t n_bits,
> BOOST_SCOPED_ENUM(alignment) A = alignment::unaligned>
> class endian_pack;
>
> The single difference between endian_pack and the original
> endian is that it don't inherits from cover_operators.

That should be the primary interface because it doesn't encourage using inefficient arithmetic operators, so that should be named boost::endian.

> > template<endian_t E1, size_t Bits, endian_t E2>
> > class endian<E1, PackedInteger<Bits, E2>> {
>
> The original endian class could be declared as
>
> template <BOOST_SCOPED_ENUM(endianness) E, typename T,
> std::size_t n_bits,
> BOOST_SCOPED_ENUM(alignment) A = alignment::unaligned>
> class endian;
>
> template <typename T, std::size_t n_bits>
> class endian< endianness::big, T, n_bits, alignment::unaligned >
> : cover_operators< endian< endianness::big, T, n_bits >, T >
> {

The class with operators should be named in such a way to indicate that it manages endianness and provides the arithmetic operators, so I suggest boost::endian_integer.

Given those names, why wouldn't endian_integer inherit from endian?

_____
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com

IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk