Subject: Re: [boost] [boost::endian] Summary of discussion #1
From: Scott McMurray (me22.ca+boost_at_[hidden])
Date: 2010-06-04 09:25:30
On 4 June 2010 09:20, Stewart, Robert <Robert.Stewart_at_[hidden]> wrote:
> "endian_pack" doesn't suggest the class' actual purpose, so a different name is in order (no pun intended). Â A "pack" of integers, as "integer::*_pack" indicates, is a collection, a set of integers, which is not the case here. Â The class also doesn't contain a collection or set of "endians." Â Even if you use "packed" as did Terry, the term is misleading because there aren't multiple integers packed into the object.
I'd guess that pack was chosen thinking of the verb, like the perl
function pack: <http://perldoc.perl.org/functions/pack.html>.