Subject: Re: [boost] [endian] endian flip and endian domain
From: Alec Ross (alec_at_[hidden])
Date: 2010-06-08 07:21:40
>> I think that I have found a good name that can be used
>> instead of the swap_in_place: "flip". This recall the flip
>> operation used in bitset exchanging the value of a bit. On
>> the endian context this will exchange in place the endianess
>> of a data from/to the native endianess.
>"Flip" is not appropriate to my mind. It works well for bits because
>they are binary, but it doesn't convey the idea of reordering
>bits/bytes to a specific sequence. I prefer my suggestion of "reorder"
>because, after all, the operation (ostensibly) reorders the data.
-- Alec Ross
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk