Subject: Re: [boost] [endian] endian flip and endian domain
From: Adam Merz (adammerz_at_[hidden])
Date: 2010-06-09 17:29:20
Stewart, Robert <Robert.Stewart <at> sig.com> writes:
> "endian_swap" doesn't connote the copying overhead so I see that as suitable to
> the in-place operation, and "endian_cast" as more appropriate to convey the
> copying operations.
I've been more or less neutral throughout this discussion -- it seems a bit
bikeshedish in that as long as the semantics are correct, the naming doesn't
warrant so much discussion. However, this is the first naming proposal I've seen
suggested that I *really* like, so +1 from me on this.
FWIW, as far as the namespace is concerned, I think the entirety of the library
should reside in the boost::endian namespace, and these two function templates
should be brought into the boost namespace via using declarations.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk