Boost logo

Boost :

Subject: Re: [boost] [boost::endian] Summary of discussion #1
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-06-14 15:11:35


vicente.botet wrote:
>
> Even if we don't have yet a clear vision of what is the
> endianness of a floating point and that we are reduced to
> interger types, I propose we name it boost::endian_holder as
> it is aware of the endianess and can contain UDT, as
> time_point, quantity::si::length ....

That's an excellent argument in favor of keeping the name generic.

> template <typename Endian, typename T, std::size_t
> n_bytes=8*sizeof(T),
> typename Alignment = alignment::aligned>
> class endian_holder;
>
> I will let the name boost::endian_integer or
> boost::integer::endian for the class providing also the
> arithmetic operations.

"endian_integer" is fine for the type with arithmetic operations, but "endian_holder" seems more circumspect that necessary. It begs questions like, "What's an 'endian' that you need a holder?"

I'd prefer to call it "endian" but you can't have a boost::endian namespace, too. Is boost::endianness a good namespace name? What about boost::order/ordering/ordered?

boost::order::endian (boost::endianness::endian) provides the basic facilities.

boost::order::endian_integer (boost::endianness::endian_integer) derives from endian and provides arithmetic operators.

_____
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com

IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk