Boost logo

Boost :

Subject: Re: [boost] [Boost-users] [BGL] Stoer–Wagner min-cut algorithm
From: Jeremiah Willcock (jewillco_at_[hidden])
Date: 2010-06-24 11:28:03


On Thu, 24 Jun 2010, Daniel Trebbien wrote:

>> - Operations on graphs and property maps (but not on tuples) need to use
>> unqualified names (such as "get" and "target") in order for ADL to work on
>> user-defined graph types that are not in the boost namespace.
>
> Do `graph_traits`, `property_traits`, `vertices`, `num_vertices`,
> `add_vertex`, `add_edge`, and `out_edges` also need qualification?

The traits classes should be qualified since they are always in the boost
namespace. Any functions from graph concepts (or other concepts like
those for property maps) should be called unqualified.

-- Jeremiah Willcock


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk