Subject: Re: [boost] [gsoc] Pointer Plus Bits Behavior and Interface
From: Sebastian Redl (sebastian.redl_at_[hidden])
Date: 2010-07-15 22:46:57
On 07/15/2010 06:48 PM, Andrew Sutton wrote:
> The class is called "pointer... plus bits". If the abstraction isn't at
> least a little bit pointer-like, then the name of the data type is
> duplicitous at best. I think that some of the suggestions treat lightly the
> attachment that programmers have to the meanings of names.
> But if you don't at least provide a boolean cast and a dereference operator,
> then I don't think you should be using "pointer" in the name of the class.
Meh, you could call it pointer_int_pair, and nobody would complain about
the "pointer" in the name. (PointerIntPair is LLVM's version of this.)