Subject: Re: [boost] accurate sum accumulator (kahan)
From: Paul A. Bristow (pbristow_at_[hidden])
Date: 2010-07-26 11:58:30
> -----Original Message-----
> From: boost-bounces_at_[hidden] [mailto:boost-bounces_at_[hidden]] On Behalf Of David Abrahams
> Sent: Monday, July 26, 2010 4:51 PM
> To: boost_at_[hidden]
> Subject: Re: [boost] accurate sum accumulator (kahan)
> At Mon, 26 Jul 2010 16:20:16 +0100,
> Paul A. Bristow wrote:
> > > At Mon, 26 Jul 2010 14:59:29 +0100,
> > > Paul A. Bristow wrote:
> > > > PS As for naming, I'd vote for sum and accurate_sum (to keep backward compatibility).
> > >
> > > It's possible I'm completely off the mark here, but I think maybe we
> > > want sum and quick_sum.
> > This would be ideal - but doesn't accumulator already use 'sum' so it would change behaviour of existing programs?
> Technically, of course it would, but aren't they getting the wrong answer currently?
Yes (a bit, sometimes, probably) - but quicker ;-)
(Seriously - a change in accuracy might mean that tests just fail and this might cause more trouble than it was worth.
This being floating point, even the Kahan method doesn't guarantee a *exact* answer, just a more accurate one).
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk