Subject: Re: [boost] accurate sum accumulator (kahan)
From: Eric Niebler (eric_at_[hidden])
Date: 2010-07-26 12:23:44
On 7/26/2010 11:51 AM, David Abrahams wrote:
> At Mon, 26 Jul 2010 16:20:16 +0100,
> Paul A. Bristow wrote:
>>> -----Original Message-----
>>> From: boost-bounces_at_[hidden] [mailto:boost-bounces_at_[hidden]] On Behalf Of David Abrahams
>>> Sent: Monday, July 26, 2010 3:10 PM
>>> To: boost_at_[hidden]
>>> Subject: Re: [boost] accurate sum accumulator (kahan)
>>> At Mon, 26 Jul 2010 14:59:29 +0100,
>>> Paul A. Bristow wrote:
>>>> PS As for naming, I'd vote for sum and accurate_sum (to keep backward compatibility).
>>> It's possible I'm completely off the mark here, but I think maybe we
>>> want sum and quick_sum.
>> This would be ideal - but doesn't accumulator already use 'sum' so it would change behaviour of existing programs?
> Technically, of course it would, but aren't they getting the wrong answer currently?
I tend to agree with Dave, so long as the kahan sum accumulator is a
drop-in replacement for what we already have. Does it Just Work for
integral types, too?
-- Eric Niebler BoostPro Computing http://www.boostpro.com