Subject: Re: [boost] [gsoc] Boost.Process done
From: Ilya Sokolov (ilyasokol_at_[hidden])
Date: 2010-09-01 18:21:36
On 01.09.2010 23:20, Boris Schaeling wrote:
> Looking at your proposed stream class I'd call it now a factory class.
> This makes sense to me and is even easier to explain (as many developers
> should be familiar with that pattern). The factory method could be
> called in create_child() making it possible to reuse contexts.
> But why did you add set_fileno()? Do we need this method if we have
> create_parent_and_child_end() already? The example looks like as if it's
> only required by inherit and thus shouldn't be added to stream really?
Probably. There is one more problem that worries me:
It is too easy to write output_stream here, and in 99% of cases
its value is input_stream.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk