Boost logo

Boost :

Subject: Re: [boost] review request: addition to type_traits library ofhas_operator_xxx
From: Nevin Liber (nevin_at_[hidden])
Date: 2010-11-17 20:53:25

On 17 November 2010 14:48, Stewart, Robert <Robert.Stewart_at_[hidden]> wrote:

> We could add has_operator_new as an alias for has_new_operator (or vice
> versa) and then the new ones would all be has_operator_* and would be
> consistent with has_operator_new.

Please don't. Most people will never remember which order it is in.
Choice actually makes things worse, as they'll get used interchangeably.
 Plus, "new operator" and "operator new" mean very different things in C++,
and most people don't remember which is which. I'd rather have one slight

 Nevin ":-)" Liber  <mailto:nevin_at_[hidden]>  (847) 691-1404

Boost list run by bdawes at, gregod at, cpdaniel at, john at