Boost logo

Boost :

Subject: Re: [boost] review request: addition to type_traits library ofhas_operator_xxx
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-11-18 07:46:40

Edward Diener wrote:
> On 11/17/2010 3:48 PM, Stewart, Robert wrote:
> > Frédéric Bron wrote:
> >
> >> At that time, we preferred has_operator_xxx to has_xxx_operator.
> >
> > I still think its better.
> I agree also. Having all the operator traits begin with
> 'has_operator_' makes their use easier to remember.
> Alternatively I could even see putting all the operator traits
> in their own namespace of 'boost::operators', dropping the
> 'operator_' in their name, and allowing the end-user to
> surface them to just the 'boost' namespace via a using
> declaration as they like.


Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP

IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.

Boost list run by bdawes at, gregod at, cpdaniel at, john at