Subject: Re: [boost] review request: addition to type_traits library ofhas_operator_xxx
From: Jeff Flinn (TriumphSprint2000_at_[hidden])
Date: 2010-11-20 13:22:47
> I prefer has_division_operator than has_operator_division, and yet more than
> division_operator ::= operator/()
I assume that for consistency that these all imply
Is that correct?
Also given the growth of EDSL's and operator overloading in general are
these names too domain specific? For example boost::filesystem overloads
operator/ for concatenating a path: p / "file.txt".
Has thought been given to more agnostic names such as:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk