Boost logo

Boost :

Subject: Re: [boost] [build] bjam in boost/tools/build/v2/test doesn't work
From: Jim Bell (Jim_at_[hidden])
Date: 2010-11-22 09:04:15

On 1:59 PM, Vladimir Prus wrote:
> Jim Bell wrote:
>> Running bjam in boost/tools/build/v2/test doesn't (seem to) run build's
>> regressions. Instead, I get:
>> jamfile.jam:8: in modules.load
>> rule project-root unknown in module
> You should be using 'python'. Running 'bjam' there is not really
> supposed to do anything.


This works and gives me results like this...
    unit_tests : FAILED
    module_actions : PASSED
    startup_v1 : PASSED

I see, too, that '--verbose' enables detailed output, from
BoostBuild.Tester's docstring (and from trying it). But it says "Note
that it does not also enable more verbose build system output like the
--verbose command line option does." What does that mean? If I run
"python --verbose verbose" it doesn't seem to like that
(attempts to run verbose.init).

Also, I'm seeing a different pass/fail pattern between when I run it
like this and when it runs from I'm running it with mingw-4.4.3
on the same trunk revision that the "MinGW-32" regression
has reported.

Picking "absolute_sources", for example, I see
    absolute_sources : PASSED

But the regression shows it failed.

How do I reconcile these?

Boost list run by bdawes at, gregod at, cpdaniel at, john at