Subject: Re: [boost] [assert] static_assert envy
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2011-01-18 10:39:46
Thorsten Ottosen wrote:
> I'm fine with BOOST_ASSERT_MSG(). Since we are adding
> assert.hpp I would
> like to see
> as well.
Is that just an alternate spelling or is there something different about the usage and meaning?
> It is really much clearer to read and maintain than
> BOOST_ASSERT( !foo() || condition );
If you just mean s/BOOST_ASSERT/BOOST_ASSERT_IF/, it hardly matters given long exposure to assert() and many variants thereof. If you mean that, instead of what you showed above, you'd write the following, I don't see the value:
Perhaps you mean that condition can be used to suppress certain assertions (and not others) without, itself, appearing in the assertion message? I've never done that, so the value is low for me, but perhaps there are good use cases I've overlooked.
If you mean something else entirely, please clarify.
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk