Boost logo

Boost :

Subject: Re: [boost] Stack-based vector container
From: Domagoj Saric (dsaritz_at_[hidden])
Date: 2011-01-25 18:44:51


"Nevin Liber" <nevin_at_[hidden]> wrote in message
news:AANLkTimWurT4NnfN4yE10SsJoEhxTZfKRALjiUGWF_NW_at_mail.gmail.com...
> Calling this StackVector is somewhat of a misnomer

I agree on the name issue...calling it a buffer is also a misnomer as it
would imply POD storage...

> Note: StackVector does not solve all combinations of (1) and (2), but its
> a
> good start. :-)

Having a:
 - resizable fixed-capacity 'vector' (basically a boost::array with an end
pointer)
 - resizable fixed-preallocated-capacitiy+to-heap-expandable vector (IOW
AutoBuffer/StackVector, can be implemented in terms of the fixed-capacity
'vector' plus the capacity and 'actual storage' pointers)
 - fixed size/non-resizable dynamically stack allocated 'vector'
 - fixed size/non-resizable dynamically heap allocated 'vector'

would, with std::array and std::vector, probably cover all areas....

-- 
"What Huxley teaches is that in the age of advanced technology, spiritual
devastation is more likely to come from an enemy with a smiling face than
from one whose countenance exudes suspicion and hate."
Neil Postman 

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk