Subject: Re: [boost] [string] proposal
From: Matus Chochlik (chochlik_at_[hidden])
Date: 2011-01-28 05:29:31
On Fri, Jan 28, 2011 at 11:20 AM, Yakov Galka <ybungalobill_at_[hidden]> wrote:
> On Fri, Jan 28, 2011 at 11:58, Matus Chochlik <chochlik_at_[hidden]> wrote:
>> On Thu, Jan 27, 2011 at 3:56 PM, Dean Michael Berris
>> <mikhailberis_at_[hidden]> wrote:
>> > On Thu, Jan 27, 2011 at 10:48 PM, Chad Nelson
>> >> The "istring" you mentioned in a later message is good enough for this
>> >> discussion, though it might not be descriptive enough for a final name.
>> > I agree. Help wanted on a better name for the immutable string. :)
>> Half-jokingly, but: what about 'chain' ? :)
>> Why not just call it boost::rope then? Its implementation will be a rope
> (almost certainly) and no-body here has to remain compatible with SGI.
I believe that some people might object to that. The original rope
has a different interface than Dean proposes.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk