Boost logo

Boost :

Subject: Re: [boost] [trunk] access denied
From: Joachim Faulhaber (afojgo_at_[hidden])
Date: 2011-02-19 19:29:16

2011/2/20 Joachim Faulhaber <afojgo_at_[hidden]>:
> Hi,
> I am unable to commit changes to trunk. Attempts (using tortoise-SVN
> on windows) result in:
> Error: access to
> '/svn/boost/!svn/act/91b0fcb8-4a55-a041-8d53-63a889463250' forbidden

I found a solution myself.

I encountered the problem described above after I struggled with the error

svn: 'x' isn't in the same repository as 'y'

when I wanted to merge changes from sandbox back to trunk.

The difference between my repository paths 'x' and 'y' was only
protocol prefix: 'http' vs. 'https'. When I changed the https to http
the merge operation finally worked. As a side effect, it seemed that
my standard repository path was now starting with 'http' instead of
'https', which seemed to affect my ability to commit the merge result
back to the trunk repository.

I tried to use the svn relocate command to change the protocol to
'https'. After that I was able to commit as usual.


Interval Container Library [Boost.Icl]

Boost list run by bdawes at, gregod at, cpdaniel at, john at