|
Boost : |
Subject: [boost] [Filesystem.v3] Request to rename imbue to something else like global_locale
From: Artyom (artyomtnk_at_[hidden])
Date: 2011-03-10 10:33:23
Hello,
The static member function
boost::filesystem::path::imbue(std::locale const &)
Is very misleading.
In the C++ standard library imbue usually refers to specific object like
specific stream and not referred to global object.
And because it is possible to write:
boost::filesystem::path p;
p.imbue(some_locale);
p="some_file.txt";
Which looks like you change p's locale and not global locale.
I'd recommend, provide static member function
boost::filesystem::path::global_locale
With same semantics as imbue and deprecate imbue.
Artyom
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk