Boost logo

Boost :

Subject: Re: [boost] [Review] Boost.Type Traits Extension by Frederic Bron
From: Vicente Botet (vicente.botet_at_[hidden])
Date: 2011-03-14 14:18:21


Hi again,

some more naming comments:

* shift operator could be named bit_left/right_shift
* has_operator_complement could be has_operator_bit_not
* prefix_ could be pre_ and suffix_ could be post_ (e.g. pre_increment and
post_increment)

BTW, could you in the documentation the list of operators that the library
don't take care and why. I'm thinking to operators ',', '()', '&' (address),
subscript . If I'm not wrong coma and address of could be implemented
without issues and call and subscript operators could be implemented with
some restrictions ("
// The function call operator has to be a member function, so it can only be
// detected for classes and unions by specialising this trait. It gives
default
// true for these.
")

The original ConceptTraits library included also traits for default
constructors and copy constructors, which have also limitations, but that
the user could specialize.

Best,
Vicente

--
View this message in context: http://boost.2283326.n4.nabble.com/Review-Boost-Type-Traits-Extension-by-Frederic-Bron-tp3353283p3354607.html
Sent from the Boost - Dev mailing list archive at Nabble.com.

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk