Boost logo

Boost :

Subject: Re: [boost] Boost.CMake status update (was: Why Boost.Build?)
From: Lars Viklund (zao_at_[hidden])
Date: 2011-03-30 19:40:08

On Thu, Mar 31, 2011 at 12:48:53AM +0200, Daniel Pfeifer wrote:
> The approach consists of two parts:
> 1. Boost.CMake is a collection of CMake modules to simplify the use and
> development of Boost libraries (at least for the subset of users and
> developers that like CMake).
> 2. Boost.Defrag is an aggregator that can collect the Boost libraries
> and tools from their individual repositories (cvs, svn, git, etc) and
> package them to a monolithic release.
> Any feedback is welcome, either here or in the issue tracker on github.

The use of Boost.NameHere strikes me as odd, as I at first glance
thought that the things mentioned were Boost libraries, as the
Boost.NameHere naming scheme is typically used for those.

In my eyes, prefixing something with "Boost." should be reserved for
libraries, not arbitrary software somewhat related to the project. As
for a more suitable naming scheme, I cannot come up with one, but I'm
sure that the list can bikeshed something together.

Previously the only offender (as far as I know) was Boost.Build. It'd be
suboptimal to confuse things more.

Lars Viklund | zao_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at