Boost logo

Boost :

Subject: Re: [boost] [Review] Type Traits Extension by Frederic Bron - Review summary and decision
From: Joachim Faulhaber (afojgo_at_[hidden])
Date: 2011-04-29 13:59:20

2011/4/29 Ivan Le Lann <ivan.lelann_at_[hidden]>:
> ----- "Joachim Faulhaber" <afojgo_at_[hidden]> a écrit :
>> Hi Frédéric, list,
> (snip)
>> To save you some time, I have inserted my proposal as column D into
>> the Wiki at
> I like those names,

I tend to appreciate that ;) After all column D contains my proposal.
But I want to stress here again that I don't like many of them and I
share many of the critiques expressed by others in this seemingly
never ending thread.

> except "has_negate".
> I would have kept "has_unary_minus", in line with proposed "has_unary_plus".
> I also wonder if "has_negate" could be mistaken for "!" by some people.

I can understand this concern for example.

The point here is that I have a strong preference for the choice of
names, which maximizes standard and cross library naming consistency.
negate is used in the standard and in Boost.Proto for entities
referring to unary operator - . So according to rules 1 and 2 on
negate is the only choice for the naming component referring to the operator.


Interval Container Library [Boost.Icl]

Boost list run by bdawes at, gregod at, cpdaniel at, john at