Boost logo

Boost :

Subject: Re: [boost] [local] Review request
From: Mostafa (mostafa_working_away_at_[hidden])
Date: 2011-05-14 21:06:25


On Sat, 14 May 2011 12:38:50 -0700, Lorenzo Caminiti
<lorcaminiti_at_[hidden]> wrote:

> Hello all,
>
> I happy to announce that I have released Boost.Local 0.2.0
> incorporating the many valuable suggestions that I have received from
> this mailing list.

<snip>

Hi Lorenzo,

I just took a quick glance at the documentation to get an understanding of
the library, and I have a suggestion/comment:

1) I suggest adding:

#ifdef ENABLE_BOOST_LOCAL_VARIADIC_WITH_DEFAULT
#define WITH_DEFAULT , default
#endif

#ifdef ENABLE_BOOST_LOCAL_SEQUENCING_WITH_DEFAULT
#define WITH_DEFAULT ) default
#endif

to the library. I think it makes client code more readable if they define
ENABLE_BOOST_LOCAL_VARIADIC_WITH_DEFAULT or its variant rather than just
defining WITH_DEFAULT.

2) In you're email you mentioned that Boost.Local functions can be used
with stl algorithms, is this noted in the web documentation?

Thanks,

Mostafa


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk