Boost logo

Boost :

Subject: Re: [boost] [local] Review request
From: Mostafa (mostafa_working_away_at_[hidden])
Date: 2011-05-16 00:49:58

On Sun, 15 May 2011 11:47:12 -0700, Lorenzo Caminiti
<lorcaminiti_at_[hidden]> wrote:

> Boost will require this macro to be named BOOST_LOCAL_WITH_DEFAULT
> even if it is controlled by the
> switch:

Oh, ok, I now see what you're saying. Thanks for the clarification.

> I found this macro names to be longer and less readable than ",
> default x" or ")(default x" so I decided not to add
> BOOST_LOCAL_WITH_DEFAULT to the library defined macros. I simply to
> suggest in the library docs that programmers can define this macro if
> they find it readable. If during the review also other programmers
> request to add BOOST_LOCAL_WITH_DEFAULT, I am happy to consider it.

Yes, given your earlier clarification, I agree with you on the readability
issue. However, I still see a use case for it, not as is, rather, the
case where clients would just alias to WITH_DEFAULT. So please consider
this my request for such an addition, in case I forget/don't participate
in the review.

Thank you,


Boost list run by bdawes at, gregod at, cpdaniel at, john at