Subject: Re: [boost] [review][assign] Formal review of Assign v2 ongoing
From: Paul A. Bristow (pbristow_at_[hidden])
Date: 2011-06-22 04:47:47
> -----Original Message-----
> From: boost-bounces_at_[hidden] [mailto:boost-bounces_at_[hidden]] On Behalf Of er
> Sent: Tuesday, June 21, 2011 10:41 PM
> To: boost_at_[hidden]
> Cc: boost-users_at_[hidden]
> Subject: Re: [boost] [review][assign] Formal review of Assign v2 ongoing
> Based on Simonson's comments I suggested an even simpler syntax, essentially renaming csv_put<I>()
> put<I>(), but for now I'll stick to what already exists.
I've been reading the docs and following this thread.
csv_put also left me thinking "Huh?" and I still can't see what 'comma separated values' has
anything to do with it.
It doesn't seem to express the 'fixed number of things' concept at all?
put seems clear enough - if you can overload it (and all csv variants) as you suggest with put<N>.
Otherwise 'put_fixed' or 'fixed_put' might be clearer?
PS Seems to me that all this assign stuff seems very complicated for something really quite simple.
It exposes the weakness in C++ language design - arrays are not 1st class citizens, and still are
not, and having POD interferes with simple initialisation. But we stuck with that :-( And I
support this assign.v2 library as a pragmatic solution, as assign.v1 was.