Subject: Re: [boost] Name and Namespace for Potential Boost Extended Floating-Point
From: Simonson, Lucanus J (lucanus.j.simonson_at_[hidden])
Date: 2011-09-01 00:22:09
Jeffrey Lee Hellrung, Jr. wrote:
> On Wed, Aug 31, 2011 at 3:16 PM, Christopher Kormanyos
>> From: Matthias Schabel <boost_at_[hidden]>
>> To: boost_at_[hidden]
>> Sent: Thursday, September 1, 2011 12:00 AM
>> Subject: Re: [boost] Name and Namespace for Potential Boost Extended
>> If this is going to be in the "multiprecision" namespace, isn't
>> "mp_*" redundant? Why not just
>> No, unfortunately not. Please remember when using a namespace, a name
>> like "float" can not be distinguished from the POD type float.
>> Remember that many developers *use* a namespace to avoid typing.
>> The ugly prefix is needed to guarantee unique naming.
> Couldn't you just do what "every" other boost library does, and
> append an underscore?
In the interest of clarity I would prefer to see mp_float and not float_ in user code that *use* the namespace.
float_ in no way intuitively means multiprecision floating point data type.
Intuitively, I would expect float_ in a boost library would mean a type that wraps a literal floating point value in a type for metaprogramming and might be declared something like:
template <float f>
float_ : float_c<f>;
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk