Boost logo

Boost :

Subject: Re: [boost] Name and Namespace for Potential Boost Extended Floating-Point
From: Joshua Juran (jjuran_at_[hidden])
Date: 2011-09-01 04:11:34

On Aug 31, 2011, at 10:46 AM, Simonson, Lucanus J wrote:

> I'd like to see the name be mp_float. I prefer:
> mp_float
> mp_int
> mp_rational
> Obviously we need the mp_ prefix if we use float and int since
> these are keywords without it.

How about


> Also, if the user puts using namespace boost::multiprecision then
> they will benefit from the prefix.

If the user writes "namespace mp = boost::multiprecision;", then the
mp_ prefix is redundant and ugly. If you really prefer to write
mp_float to mp::floating, you can still "typedef
boost::multiprecision::floating mp_float;".

> I prefer multiprecision to mp since the library name I'm guessing
> would be multiprecision and it is conventional to have the
> namespace be the same as the library name.

I agree here. But the user is free to alias the namespace to
something more succinct and convenient.


Boost list run by bdawes at, gregod at, cpdaniel at, john at