Subject: [boost] [Review:Algorithms]
From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2011-09-26 13:23:55
Some minor comments based on reading the docs only.
A. xxx_of_val should be named xxx_of_equal or something IMO, or the name
should simply be overloaded.
B. Documentation for clamb: I dislike the "iff". Just say "if", because
this doesn't clash with the case v==lo/hi. Use the names low/high or
lower_bound/upper_bound. The "High point" terminology may be replaced
with "upper bound" IMO.
C. (ordered) I think the cannonical way is to use
(and similar for other names) in the documentation.
E. A small code example on each page would be nice.
F. Why is there no range-based versions of Boyer-Moore etc.?
G. You could consider to present the iterator version and the range
version of all algorithms on the same page.
H. I couldn't fine any details about detail::BM_traits<>. Do I need to
know about these?
I think this is a useful, minor addition to Boost.
I vote "yes" for inclusion.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk