Boost logo

Boost :

Subject: Re: [boost] [Review:Algorithms]
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2011-09-26 14:22:08

Marshall Clow wrote:
> On Sep 26, 2011, at 10:23 AM, Thorsten Ottosen wrote:
> > A. xxx_of_val should be named xxx_of_equal or something IMO,
> > or the name should simply be overloaded.
> I will think about "any_of_equal". It doesn't seem right to me
> at first look - but then again, "any_of_val" is not a great
> name either.

I think the previous suggestion of "any_equal" is spot on.

> > D. write
> >
> > #include <boost/algorithm/search.hpp>
> >
> > instead of
> >
> > Header 'search.hpp'
> >
> > (and similar for other names) in the documentation.
> They're already referenced as "Header
> <boost/algorithm/all.hpp>" in the reference section.
> Do you think that I should match those, or use "#include
> <boost/algorithm/all.hpp>" as the section titles?

They all should be "#include <boost/algorithm/all.hpp>" so one can copy and paste straight from the documentation to a source file.

Rob Stewart robert.stewart_at_[hidden]
Software Engineer using std::disclaimer;
Dev Tools & Components
Susquehanna International Group, LLP


IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.

Boost list run by bdawes at, gregod at, cpdaniel at, john at