Boost logo

Boost :

Subject: Re: [boost] Interest in StaticVector - fixed capacity vector
From: Krzysztof Czainski (1czajnik_at_[hidden])
Date: 2011-10-14 11:33:36

Krzysztof Czainski:
> +1 for policy based from me. I can imagine using different
> policy StaticVectors in the same app.

Andrew Hundt:

> > Side note:
> > Can anyone think of a better name than unchecked_push_back?

2011/10/14 Paul A. Bristow <pbristow_at_[hidden]>:

> push_back_unchecked ?
> Then it will appear in the sensible place in any alphabetical list of
> functions.

I think having both checked, and unchecked versions is a good idea. I prefer
the name push_back_unchecked for the same reason, as Andrew.

However, I'd still like to have the option of choosing a policy for the
"ckecked" versions, so I can pass different StaticVectors to the same
algorithm in different contexts: a checking-one-way version of StaticVector,
or a checking-another-way version, or maybe a not-checking version. This
maybe sounds dangerous, but I would like that to be possible.


Boost list run by bdawes at, gregod at, cpdaniel at, john at