Subject: Re: [boost] Boost.Local Review (Nov 10, 2011 to Nov 19, 2011)
From: Jeffrey Lee Hellrung, Jr. (jeffrey.hellrung_at_[hidden])
Date: 2011-11-14 19:25:51
On Mon, Nov 14, 2011 at 4:00 PM, Lorenzo Caminiti <lorcaminiti_at_[hidden]>wrote:
> As it was suggested, I'm thinking that I will change from this_ to
> _this (to be consistent with Phoenix) and require to use _this in both
> the local function declaration and implementation (and error at
> compile-time if you use this instead of _this in the declaration but I
> still can't error if you mistakenly use this instead of _this in the
> definition :( ). I will also leave the config macro so the users can
> change this name if they want/need to.
I think it would be more consistent with other Boost libraries to use
"this_" rather than "_this".
A leading underscore is used to distinguish domain-defined keywords and
placeholders. This *kind of* fits that, but...well, to me, not exactly.
On the other hand, one would almost certainly prefer to just use "this",
except...you can't. Anytime you want to use a C++ keyword as an identifier
but can't actually use the keyword verbatim, the consistent practice has
been to append an underscore.
Just my opinion, and it's not a big deal either way,
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk