Boost logo

Boost :

Subject: Re: [boost] [rfc] lockfree API/naming suggestions
From: Tim Blechmann (tim_at_[hidden])
Date: 2011-11-29 13:39:18

> > "single_thread_push" might cause some misunderstanding, as people may
> > think that it is about a `single producer', not about a
> > `single-threaded use'. so it is really a "thread_unsafe_push", as
> > incorrect use may corrupt the internal data structure.
> >
> > so maybe "thread_unsafe_push", "nonblocking_push" and "push"?
> if there is resistance for unsafe_push, I propose push_unsynchronized
> (or unsynchronized_push).

very good idea! unsynchronized is much more expressive than unsafe.

thanks, tim

Boost list run by bdawes at, gregod at, cpdaniel at, john at