Boost logo

Boost :

Subject: Re: [boost] [closure] name (was: Re: "protected" APIs)
From: Thomas Klimpel (Thomas.Klimpel_at_[hidden])
Date: 2012-01-04 20:12:26

lcaminiti wrote:
> Thomas Heller-7 wrote
> > Boost.Closure?
> > [snip]
> > I really don't like that name is at implies functional programming
> > capabilities.
> > Didn't you decide to name it Boost.LocalFunction instead?
> I'm equally happy with LocalFunciton or Closure. My review manager and one
> of the reviewers expressed a strong preference for Closure because a shorter
> name and more to the point of the library purpose so I'm adopting that name.

I have to admit that Boost.Local_Function sounds like a nice name to me, especially if the library implements "only" local functions. If local blocks and local exits would still be part of the library, I could understand why Boost.Closure might also be attractive, but I thought...

But if you want to stress that the local functions created by the library can be returned easily from a function without taking special precautions (I don't know whether this is actually true), then Boost.Closure might not be a bad name after all.


Boost list run by bdawes at, gregod at, cpdaniel at, john at