Subject: Re: [boost] [functional] adding overload
From: Nathan Ridge (zeratul976_at_[hidden])
Date: 2012-01-15 21:06:12
> During Boost.Local review, it was proposed to move the overload
> template out of Local and in Boost.Functional. What would the best
> name for it?
> 1) boost::overload_function (my preference)
> 2) boost::overloaded_function
> 3) boost::function_overload
> 4) boost::functional::overload (Boost.Functional seems to use boost::
> directly and not boost::functional-- to mimic C++11 ).
I like boost::functional::overload. You can then add a convenience
function make_overload() with creates one without having to specify
the template parameters, and it will be at once intuitive-sounding
and consistent with Boost naming conventions.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk