Boost logo

Boost :

Subject: Re: [boost] [PREDEF] Review for the Boost.Predef library by Rene Riviera
From: Iain Denniston (iain.denniston_at_[hidden])
Date: 2012-02-28 13:47:49

On 27/02/2012 17:02, Iain Denniston wrote:
> - The version macros seem to be missing some obvious, um, versions, if
> they are intended to be used by users and to extend the library it
> would be good to see all “obvious” versions supported out of the box
> (e.g. “NN”, “NN_NN_NN_NN” and I note that Windows version numbers
> would require a “NNNN_NN_NN”)

Oh for crying out loud - seems I needed more caffeine/sleep before I
posted this. Sigh.

NN_NN_NN_NN should be NN_NN_NN_00 and that is actually what Windows
version numbers need.

Also want to add that these macros are not really very clearly named,
though its not clear what would be a better naming scheme - my best
effort so far is something like:


If the expectation is that predef/these macros are to be taken up by
others an expanded to further things, then I think these macros need to
be better. If they are expected to remain internal to the library then
I'm just being picky (and am happy to be ignored) :P


Boost list run by bdawes at, gregod at, cpdaniel at, john at