Boost logo

Boost :

Subject: Re: [boost] Latest changes to scoped enum emulation break existing code
From: Vicente J. Botet Escriba (vicente.botet_at_[hidden])
Date: 2012-05-13 04:04:53

Le 13/05/12 00:21, Jeffrey Lee Hellrung, Jr. a écrit :
> On Sat, May 12, 2012 at 10:30 AM, Vicente J. Botet Escriba<
> vicente.botet_at_[hidden]> wrote:
>> I have changed the names of the native and underlying functions to
>> get_native_value_ and get_underlying_value_. I hope that these names will
>> not be used as names for literals of an enum type.
>> svn ci boost/detail -m "ScopedEnum: Fix issue with native() function clash"
>> Sending boost/detail/scoped_enum_**emulation.hpp
>> Transmitting file data .
>> Committed revision 78437.
> If these functions are indeed not exposed to the interface (are they
> brought into user code via a macro or something?), then why not something
> really specialized like _boost_scoped_enum_native and
> _boost_scoped_enum_underlying?
Yes, why not. I'll change them if these are considered safer.


Boost list run by bdawes at, gregod at, cpdaniel at, john at