Subject: Re: [boost] [1.50.0] Beta 1 release candidates available for testing
From: Daniel James (dnljms_at_[hidden])
Date: 2012-06-02 05:05:36
On 1 June 2012 23:19, Stephan T. Lavavej <stl_at_[hidden]> wrote:
> [Daniel James]
>> if that's the
>> case then IMO it'd better if they named it something different, since
>> it's used differently and it'd allow a smoother transition when they
>> are implemented.
> I don't think that that would buy anything. You'll get compiler errors either way (expecting real template aliases and getting fake, or vice versa), so changing the name wouldn't do anything - you'd still need an #ifdef.
When template aliases become available, to use them you'll need to
replace 'rebind_alloc' which will break any code which uses the
'other' member. If you used a different name then you could leave that
in alongside the template alias so that existing code would continue
to work. It'd also have been a more useful error message, if it just
said that 'rebind_alloc' isn't available, I'd have instantly known
what the issue was, instead there was an odd error about 'value_type'.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk