Boost logo

Boost :

Subject: Re: [boost] Formal Review Request: TypeErasure (docs, Concept Maps misnamed?)
From: lcaminiti (lorcaminiti_at_[hidden])
Date: 2012-06-21 19:49:24

Steven Watanabe-4 wrote
> On 06/21/2012 10:34 AM, Larry Evans wrote:
>> The page:
>> */libs/type_erasure/doc/html/boost_typeerasure/conceptdef.html
>> uses the term 'primitive concept':
>> A primitive concept must be a specialization of a class template,
>> with a static member function called apply.
>> What's the difference between a 'Concept Map' and 'primitive concept'?
>> If they are the same, why not use the same term for both?
>> [snip]
> They aren't the same. A primitive
> concept specified the interface and
> (optionally) a default Concept Map.
> A Concept Map specifies how a specific
> type models the concept.

I read the docs and didn't find the concept naming confusing (on the
contrary, it's "standard" terminology). However, I agree that a Wiki link to
concepts would be useful from in the docs as not all readers will be
familiar with the C++0x concept proposals:


View this message in context:
Sent from the Boost - Dev mailing list archive at

Boost list run by bdawes at, gregod at, cpdaniel at, john at